Oracle Linux 6, oracle-validated is missing? no renamed!

In Oracle Linux 6, it looks like the ‘oracle-validated’ package is missing, but Oracle actually renamed it to ‘oracle-rdbms-server-11gR2-preinstall.x86_64‘.

To quickly use the public yum repository of Oracle and install ‘oracle-rdbms-server-11gR2-preinstall.x86_64’:

cd /etc/yum.repos.d
wget http://public-yum.oracle.com/public-yum-ol6.repo
#vi /etc/yum.repos.d/public-yum-ol6.repo
yum clean all
yum repolist
yum install oracle-rdbms-server-11gR2-preinstall.x86_64

You will get the ‘latest’ build enabled.
If you don’t want this, vi /etc/yum.repos.d/public-yum-ol6.repo .

Happy installing!

Public yum package ‘oracle-validated’ problems on 64bit OEL

I was preparing some fresh installed OEL5.5 machines for database software installation, but after running ‘yum install oracle-validated‘, the OUI did not pass the prerequisites on two packages. It seems it did not install unixODBC-devel x86_64 and libaio-devel x86_64.

Their Linux may be unbreakable, but their ‘oracle-validated’ package on the public yum server seemed to be broken. Continue reading