Issues installing 11.2.0.4 (and 11.2.0.3) on Linux 7 (RHEL7 and OEL7)

REHL 7 and Oracle Linux 7 was not released when Oracle database 11.2.0.4 came out, so the installer does give some issues in the pre-requisites and when installing the software. I advice to do a software only installation first, because of an issue that you will need to fix with a patch after software installation, but before creating a database.

These issues popped-up when I was installing a 11.2.0.3 database on RHEL7 (not a Certified product combination!), but the solutions given for 11.2.0.4 worked for it as well:

  • elfutils-libelf-devel package missing;
  • compat-libstdc++ package missing;
  • pdksh package missing;
  • “Error in invoking target ‘agent nmhs’ of makefile” when installing.
    • This one also counts for installing Oracle Fusion Middleware.

Missing packages

Missing Packages

Missing Packages


elfutils-libelf-devel

This is a pre-requisite in the installer, but it’s not mentioned in the documentation.

That could be reason why you have missed it. It is available on the installation media and in the RHEL7/OEL7 yum repository.

Solution: Install it.


compat-libstdc++

This one is not available on the RHEL7 installation media or in the yum repository, but it is on the OEL7 ones.
The doc ‘Requirements for Installing Oracle 11.2.0.4 RDBMS on OL7 or RHEL7 64-bit (x86-64) (Doc ID 1962100.1)’ shows it as present as “default-RPMs”, but that must be a OEL7 screenshot. According to ‘Installation of 12.1.0.2 Oracle Database Server/Client on RHEL 7/OL7 reports pre-requisite package ‘compat-libstdc++’ missing. (Doc ID 2062336.1)’.

It’s a bug and the solution is ‘Install the compat-libstdc++-33-3.2.3 and Proceed with the Database Installation.’, but that’s pretty hard if you don’t have it.  The bug description tells you something else: ‘Workaround: Ignore the package requirement and continue with installation as it is not required package’, so ignore it.

Solution: Ignore it.


pdksh

This one is not available on both the RHEL7 and OEL7 installation media or in the yum repository.

According to ‘Missing pdksh-5.2.14 package during Oracle database 11.2.0.4 install on Oracle Linux 7 (Doc ID 1962046.1)’, it’s a bug and it’s not required.

Solution: Ignore it.


Error in invoking target ‘agent nmhs’ of makefile

Error in invoking target 'agent nmhs' of makefile

Error in invoking target ‘agent nmhs’ of makefile

This one pops-up when the installer is running after ignoring the missing two packages. I’m not sure it’s a consequence of ignoring them, but according to ‘Installation walk-through – Oracle Grid/RAC 11.2.0.4 on Oracle Linux 7 (Doc ID 1951613.1)’, you can press Continue and need to patch the home before creating a new database. It seems a DB Control issues, so maybe if you don’t use it, you don’t need it. The patch is only available for 11.2.0.4, not 11.2.0.3.

Solution (read notes below): Continue and patch with p19692824 before creating databases.
note 1
: the patch tells you *NOT* to continue and edit “$ORACLE_HOME/sysman/lib/env_emagent.mk” before continuing. I can confirm this works (on 11.2.0.3).
note 2: on 11.2.0.3, the patch does not work: “Patch 19692824: Required component(s) missing : [ oracle.sysman.agent, 10.2.0.5.6 ]”, this is probably due to the fact the agent is of version 10.2.0.4.3 instead of 10.2.0.5.
note 1+2: on 11.2.0.4, it might be that only ‘Continuing’ and patching afterwards works. Sorry, I did not test this.

 


Installing with ignoring errors, patching the installer, patching the patch tool… it’s an Oracle thing!

Tagged , , , . Bookmark the permalink.

Leave a Reply

Your email address will not be published. Required fields are marked *